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Service Not Reachable

Problem

Applications cannot access a Kubernetes service.

Symptoms

  • application cannot connect to service
  • requests time out
  • service returns connection errors

Investigation

Verify the service exists:

kubectl get services

Check endpoints:

kubectl get endpoints

Inspect service configuration:

kubectl describe service my-service

Verify pods are running:

kubectl get pods


Common Causes

Typical causes include:

  • pods not running
  • incorrect service selector
  • network policy blocking traffic
  • incorrect service type

Resolution

Possible solutions:

  • update service selectors
  • ensure pods match labels
  • review network policies
  • verify container ports

Prevention

Best practices:

  • validate service selectors
  • monitor service endpoints
  • use consistent labeling